Aller au contenu

Notes de publication pour Rocky Linux 9.1

Mise à jour

Vous pouvez mettre à jour de Rocky Linux 9.0 vers Rocky Linux 9.1 en lançant simplement la mise à jour sudo dnf -y upgrade

Note

Rocky Linux ne propose pas de mise à niveau à partir d'une installation en Rocky Linux 8. Nous vous recommandons de faire une nouvelle installation du système d'exploitation pour passer à Rocky Linux 9.x.

Changements concernant les images

En plus des images classiques d'installation, il y a plusieurs images disponibles pour les nouvelles plates-formes cloud et conteneurs existantes.

Entre Rocky Linux 9.0 et 9.1, des images pour Oracle Cloud Platform (OCP) ont été développées et publiées. Les images Oracle se joignent à notre jeu d'images existant, comprenant GenericCloud, Amazon AWS (EC2), Container RootFS/OCI, Google Cloud Platform, Microsoft Azure et d'autres images gérées pour les CSP.

De plus, les images GenericCloud, EC2 et Azure ont maintenant une version utilisant une partition LVM pour le système de fichiers racine, permettant aux administrateurs de systèmes une plus grande flexibilité et des options supplémentaires pour la configuration de leurs systèmes. Et l'image GenericCloud est aussi disponible pour ppc64le et s390x dès maintenant !

Aussi le pipeline de construction pour les images de conteneur (Base, Minimal et UBI) et de Vagrant (Libvirt, VirtualBox et VMWare) a été remanié. Les images de Vagrant sont maintenant disponibles pour x86_64 et aarch64, et les images de conteneur pour les 4 architectures.

Plus d'informations sur les artefacts produits par le groupe d'intérêt spécial Cloud, ainsi que des informations sur la façon de s'impliquer peuvent être trouvées sur la page SIG/Cloud Wiki.

Installation

Pour installer Rocky Linux 9.1, rendez-vous sur la page de téléchargement et téléchargez la version dont vous avez besoin pour votre architecture.

Problèmes connus

Changements majeurs

Pour une liste complète des changements majeurs, veuillez consulter la liste amont ici.

Quelques faits saillants de cette version sont détaillés ensuite.

Gestion des logiciels

  • La commande modulesync est maintenant disponible pour remplacer certains workflows dans dnf et createrepo_c.

Sécurité

Modifications apportées à OpenSSH

  • La nouvelle option prend en charge la définition de la longueur minimale de la clé RSA
  • crypto-polices impose une longueur minimale de la clé RSA de 2048 bits par défaut
  • crypto-polices prennent maintenant en charge sntrup761x25519-sha512@openssh.com

Changements apportés à SELinux

  • La statégie SELinux confine des services supplémentaires
  • SELinux prend en charge le mot-clé self dans les transitions de type
  • Mise à jour des paquets SELinux concernant l'espace utilisateur
  • Le relabeling automatique de SELinux est maintenant exécuté en parallèle par défaut

Autres modifications

  • Nouvelle option dans OpenSSL qui prend en charge SHA-1 pour les signatures
  • Les services de sécurité réseau (Network Security Services - NSS) ne prennent plus en charge les clés RSA inférieures à 1023 bits
  • Guide de sécurité SCAP rebasé sur 0.1.63
  • Nouveaux paquets : keylime un outil de validation de systèmes distants, qui utilise la technologie de la plateforme de confiance (Trusted Platform Module - TPM). Avec Keylime, vous pouvez vérifier et surveiller en permanence l'intégrité des systèmes distants.
  • Ajout d'une option de taille maximale pour les fichiers d'erreur Rsyslog
  • clevis-luks-askpass est maintenant activé par défaut
  • fapolicyd rebasé sur 1.1.3

Shells et outils en ligne de commande

  • Cronie ajoute la prise en charge d'un temps aléatoire parmi une plage sélectionnée
  • ReaR ajoute de nouvelles variables pour l'exécution de commandes avant et après la restauration
  • Nouveau paquet : xmlstarlet - Un ensemble d'utilitaires en ligne de commande pour l'analyse, le transformation, la requête, la validation et l'édition de fichiers XML
  • pencryptoki rebasé sur la version 3.18.0
  • powerpc-utils rebasé sur la version 1.3.10
  • libvpd rebasé sur la version 2.2.9
  • lsvpd rebasé sur la version 1.7.14
  • ppc64-diag rebasé sur la version 2.7.8
  • sysctl introduit une syntaxe identique pour les arguments comme systemd-sysctl

Services d'infrastructure

Modifications apportées à chrony

  • utilise maintenant les serveurs DHCPv6, NTP ainsi que DHCPv4
  • rebasé sur la version 4.2

Autres modifications

  • unbound rebasé sur la version 1.16.2
  • La fonction de cryptage du mot de passe est maintenant disponible dans whois
  • frr rebasé sur la version 8.2.2

Réseaux

  • Le module du noyau act_ctinfo a été ajouté
  • Le pilote PTP prend désormais en charge les horloges virtuelles et l'horodatage
  • firewalld a été rebasé sur la version 1.1.1
  • NetworkManager prend maintenant en charge les attributs de route advmss, rto_min et quickack
  • Support de l'option 802.ad du vlan-protocol dans nmstate
  • Plus d'attributs d'auto-configuration DHCP et IPv6 ont été ajoutés à l'API nmstate
  • NetworkManager indique maintenant clairement que le support WEP n'est pas disponible

Haute Disponibilité et Clustering

  • pcs prend en charge la mise à jour des périphériques SCSI multipath sans nécessiter un redémarrage du système
  • Prise en charge de l'UUID du cluster
  • Nouvelle option de commande pcs resource config pour afficher les commandes pcs qui recréent les ressources configurées
  • Nouvelle option de commande pcs stonith config pour afficher les commandes pcs qui recréent les dispositifs de protection configurés
  • Pacemaker rebasé sur la version 2.1.4
  • Samba n'est plus automatiquement installé avec les paquets du cluster

Langages de programmation, serveurs Web et Bases de Données

Module Streams

  • Un nouveau flux de module : php:8.1
  • Un nouveau flux de module : ruby:3.1

Autres modifications

  • httpd rebasé sur la version 2.4.53
  • Une nouvelle valeur par défaut pour la directive LimitRequestBody dans la configuration de httpd
  • Nouveau paquet : httpd-core
  • pcre2 rebasé sur la version 10.40

Compilateurs et outils de développement

Module Streams

  • Un nouveau flux de module : maven:3.8

Nouveau GCC Toolset 12

  • GCC Toolset 12 : Annobin rébasé sur la version 10.79
  • GCC Toolset 12 : binutils rebasé sur la version 2.38
  • Les versions GCC 12 et suivantes supportent _FORTIFY_SOURCE level 3
  • GCC Toolset 12 : GDB rebasé sur la version 11.2

Autres modifications

  • Le compilateur GCC 11.2.1 a été mis à jour avec de nombreuses corrections de bugs et améliorations
  • La configuration du stub resolver DNS supporte maintenant l'option no-aaaa
  • GDB prend en charge les instructions Power 10 PLT
  • Rust Toolset rebasé sur la version 1.62.1
  • L'ensemble d'outils LLVM a été rebasé sur la version 14.0.0

Gestion d'identité

Changements SSSD

  • SSSD prend maintenant en charge le cache mémoire pour les requêtes SID
  • Support SSSD pour anonymous PKINIT for FAST
  • SSSD prend maintenant en charge l'intégration directe avec Windows Server 2022

Modifications apportées à IdM

  • IdM supporte maintenant les numéros de série aléatoires
  • L'IdM prend maintenant en charge une limite au nombre de liaisons LDAP autorisées après l'expiration du mot de passe utilisateur
  • IdM prend maintenant en charge la configuration d'un AD Trust avec Windows Server 2022

Autres modifications

  • Nouveaux rôles ipasmartcard_server et ipasmartcard_client
  • Les messages de débogage ipa-dnskeysyncd et ipa-ods-exportateur ne sont plus enregistrés dans /var/log/messages par défaut
  • samba rebasé sur la version 4.16.1
  • Directory Server supporte maintenant les opérations de suppression récursive lors de l'utilisation de ldapdelete

Virtualisation

  • Amélioration de la conformité de l'architecture KVM
  • open-vm-tools rebasés sur 12.0.5

Signaler des bugs

Veuillez signaler tout bug que vous rencontrez sur le Rocky Linux Bug Tracker. Nous vous invitons également à rejoindre notre communauté de quelque manière que ce soit sur nos Forums, Mattermost, IRC sur Libera.Chat, Reddit, Mailing Lists, ou toute autre manière si vous souhaitez participer !


Dernière mise à jour: 1 décembre 2022