跳转至

Rocky Linux 9.0的发布说明

重大变化

有关主要变化的完整清单,请参阅此处的上游清单。

请检查 CPU 兼容性

在Rocky Linux 9.0下,一些旧的 CPU 将无法正常运转,或许根本无法正常运转。 以下架构是系统安装成功的最低硬件要求:

  • 64 位架构的 AMD 和 Intel (x86-64-v2)
  • 64 位 ARM 架构 (ARMv8.0-A)
  • IBM Power Systems, Little Endian (POWER9)
  • 64 位 IBM Z (z14)

有关支持的架构和使用不支持的架构带来的风险的更多信息,请参阅 此处 有关该主题的上游发布说明。

下文将详细介绍此次发布版本的一些亮点。

新的Build系统 (Peridot)

Rocky Linux 9是由我们内部开发的、开源的名为 Peridot 的原生云构建系统精心构建的。 Peridot被用于为x86_64、arch64、s390x和ppc64le架构构建的Rocky Linux 9。

在其他方面,这个版本代表了我们对社区的长期承诺——即通过让用户从头开始自由的构建、增强或复制Rocky Linux的方式,来确保Rocky Linux项目的长久性。 构建系统的源代码可在 此处 获得

安全

  • 使用 SHA-1 对消息摘要进行加密的算法已被弃用, 因为SHA-1生成的加密散列函数不再被认为是安全的。 例外情况请见上面的上游链接。
  • OpenSSL 现在是 3.0 版本,此版本有许多的改进,包括诸如提供程序的概念、新版本的计划、改进的 HTTP(S) 客户端、支持新协议、格式和算法等等。
  • OpenSSH 现在是 8.7p1 版本,此版本有许多改进,最明显的是用提供更多可预测文件名处理的SFTP协议取代了SCP/RCP协议。
  • SELinux 的性能、内存开销、加载时间都得到了显著改进。 上游的版本发布说明中有着许多更详细的变更。
  • Rocky Linux 9支持直接通过Anaconda安装程序自动配置PCI-DSS、HIPAA、DISA以及其他许多安全合规方面的设置,从而节省时间和精力,以满足在快速发展的安全领域的复杂要求。

网络

与网络相关的主要变化如下所示。 有关这些变化以及其他与网络相关变化的详细覆盖面,请访问 此处 的上游链接。

  • mptcpd 或 MultiPath TCP 守护程序,可以替代 iproute2 来配置MultiPath TCP 端点。
  • NetworkManager现在默认使用密钥文件来存储新的连接配置文件,但仍然支持使用 ifcfg
  • iptables-nftipset 现已被弃用,其中包括软件包工具,如 iptablesip6tablesebtablesarptables。 这些都被 nftables 框架所取代。
  • network-scripts 软件包已被移除, 转而使用的是 NetworkManager 来配置网络连接。

Web和编程

接下来列出的几个动态编程语言、版本控制系统以及 web 相关的应用套件已经在Rocky Linux 9.0中更新到了较新的版本。 有关完整的变化清单和描述,请参阅 这个上游链接

动态编程语言

  • Node.js 16
  • Perl 5.32
  • PHP 8.0
  • Python 3.9
  • Ruby 3.0

版本控制系统

  • Git 2.31
  • Subversion 1.14

Web 服务器

  • Apache HTTP Server 2.4.51
  • nginx 1.20

代理缓存服务器

  • Varnish Cache 6.6
  • Squid 5.2

数据库服务器

  • MariaDB 10.5
  • MySQL 8.0
  • PostgreSQL 13
  • Redis 6.2

编译器和开发工具

有关完整的详细变化清单,请参阅 这个上游链接 。 重点内容如下:

系统工具链

  • GCC 11.2.1
  • glibc 2.34
  • binutils 2.35.2

性能和调试工具

  • GDB 10.2
  • Valgrind 3.18.1
  • SystemTap 4.6
  • Dyninst 11.0.0
  • elfutils 0.186

性能监测工具

  • PCP 5.3.5
  • Grafana 7.5.11

编译器工具集

  • LLVM Toolset 13.0.1
  • Rust Toolset 1.58.1
  • Go Toolset 1.17.7

Java 实现

提供了以下的 Java 运行环境和 Java 开发套件:

  • java-17-openjdk
  • java-11-openjdk
  • java-1.8.0-openjdk

提供了以下 Java 工具:

  • Maven 3.6
  • Ant 1.10

虚拟化

关于虚拟化中的变化和增强功能的完整列表,请参阅 此上游链接

主要的亮点是:

  • QEMU现在是使用CLANG编译器构建,该编译器允许 KVM Hypervisor 使用许多高级的安全与调试功能。
  • 现在完全支持 vTPM(Virtual Trusted Platform Module,虚拟可信平台模块)。
  • virtiofs 功能已经实现,你可以用它来更有效地在 Rocky Linux 主机和它的虚拟机之间共享文件。
  • cgroup-v2 实现了单一的层次结构模型,它现在是9.0中的默认 Linux 控制组。 这将对那些使用基于容器化的系统(Docker、Kubernetes等)产生一些影响。 更多信息请见上面的链接。

系统升级

Rocky Linux团队不建议从一个主要版本升级到另一个主要版本(在这种情况下为8.6至9.0)。 虽然在主要版本之间进行升级在技术上是可行的,但我们建议重新安装所需的最新主要版本。

安装

若要安装 Rocky Linux 9.0,请前往 下载页面 并下载您的架构所需的版本。 Rocky Linux 9.0的完整安装指南可在 Rocky Linux 文档网站 上找到。

虽然这在(上面的)安装指南中有所涉及,但重要的是你要根据该文件的 CHECKSUM 验证你的下载,以确保没有损坏或篡改。 假设你已经在另一台使用Linux的机器上下载了该文件,则可以通过以下步骤完成此操作:

  • 在您下载目标架构的 ISO 镜像的目录中,下载CHECKSUM 文件。 示例:
curl https://download.rockylinux.org/pub/rocky/9/isos/x86_64/CHECKSUM -o CHECKSUM
  • 然后运行命令:
sha256sum -c CHECKSUM --ignore-missing
  • 如果您在命令行上返回以下内容,则表示您的文件已经通过了验证。 请注意,我们假设以下是 minimal ISO,但也可能是DVD ISO:
Rocky-9.0-x86_64-minimal.iso: OK

另外,你也可以通过到 这里的github存储库 获得任何 Rocky Linux 发布版本的 checksums。

已知问题

与任何版本一样,存在一些已知的问题。 您可以在 这里 查看来自上游的当前问题清单。

  • 使用 Minimal ISO 安装的限制——大多数与安全有关的软件包将无法工作。 如果你在安装时需要与安全相关或SCAP的配置文件以及软件包,请使用DVD ISO。

报告bug

请向 Rocky Linux Bug Tracker 报告您遇到的任何bug。 我们也欢迎您以任何方式加入我们的社区,不管是在我们的 ForumsMattermostIRC on Libera.ChatRedditMailing Lists,还是其他任何您希望参与的方式。


最后更新: 2022年12月1日